logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
iperione  
#1 Posted : Sunday, November 22, 2020 3:07:45 AM(UTC)
iperione

Rank: Newbie

Groups: Registered
Joined: 10/11/2020(UTC)
Posts: 7
Italy
Location: rome

Hi everyone,
I have this issue...
I need to stream on Mainstreaming using vMix.
I've got the RTMP for the streaming, that works correctly with OBS studio...

rtmp://bc.msmdn.net/event/..../....

I just copied and pasted it on vMix, but doesn't work

My stream settings are H264 1080p 3mbps AAC 128kbps

(tryed also with 720p resolution)

it says:

[rtmp @ 04e2aee0] Detected librtmp style url parameters, these aren't supported by the libavformat RTMP handler currently enabled.

FFMPEG1.Exited
configuration: --enable-gpl --enable-version3 --enable-libx264 --enable-zlib --enable-libfaac --enable-nonfree --cpu=i686 --enable-nvenc
libavutil 55. 2.100 / 55. 2.100
libavcodec 57. 3.100 / 57. 3.100
libavformat 57. 2.100 / 57. 2.100
libavdevice 57. 0.100 / 57. 0.100
libavfilter 6. 9.100 / 6. 9.100
libswscale 4. 0.100 / 4. 0.100
libswresample 2. 0.100 / 2. 0.100
libpostproc 54. 0.100 / 54. 0.100
Guessed Channel Layout for Input Stream #0.1 : stereo
Input #0, dshow, from 'video=vMix Video YV12:audio=vMix Audio':
Duration: N/A, start: 6040.165000, bitrate: 1536 kb/s
Stream #0:0: Video: rawvideo (YV12 / 0x32315659), yuv420p, 1920x1080, 25 tbr, 10000k tbn, 25 tbc
Stream #0:1: Audio: pcm_s16le, 48000 Hz, 2 channels, s16, 1536 kb/s
[rtmp @ 04e2aee0] Detected librtmp style URL parameters, these aren't supported by the libavformat internal RTMP handler currently enabled. See the documentation for the correct way to pass parameters.
[tcp @ 04e2b320] TCP Buffer has been set to 7820288 bytes
[dshow @ 02997fe0] real-time buffer [vMix Video YV12] [video input] too full or near too full (65% of size: 128000000 [rtbufsize parameter])! frame dropped!
[rtmp @ 04e2aee0] Server error: The publisher's IP was rejected
rtmp://bc.msmdn.net/event/S94382317/1398676416/obs test: Operation not permitted
[dshow @ 02997fe0] real-time buffer [vMix Video YV12] [video input] too full or near too full (70% of size: 128000000 [rtbufsize parameter])! frame dropped!
MycroBeat99  
#2 Posted : Sunday, November 22, 2020 6:38:05 AM(UTC)
MycroBeat99

Rank: Member

Groups: Registered
Joined: 8/31/2015(UTC)
Posts: 28
Man
Romania
Location: Romania

Thanks: 10 times
Was thanked: 2 time(s) in 2 post(s)
According to your description, may be a problem to ffmpeg from vMix.
vMix use an old version of ffmpeg and don't know the all the advanced features from latest release.

standard rtmp: rtmp://IP_OR_DOMAIN/application_name/stream_name
advanced rtmp: rtmp://IP_OR_DOMAIN/application_name/another_stuff/stream_name

Try to use External and encode using OBS or using the latest version of ffmpeg from website if you want to use the advanced type of rtmp (via capture the vMix Video or vMix Video External 2 on dshow).
iperione  
#3 Posted : Sunday, November 22, 2020 7:38:36 AM(UTC)
iperione

Rank: Newbie

Groups: Registered
Joined: 10/11/2020(UTC)
Posts: 7
Italy
Location: rome

Thankyou for the answer.

For working purposes, I already installed on my pc the latest release of FFMPEG.

It was already planned to use obs, using a capture device (atem mini or ultrastudio recorder), to stream on mainstreaming.
But I would really like to use vmix for streaming in order to use an external 4k monitor to manage its interface...

I hope someone could tell us how to bypass this issue.
iperione  
#4 Posted : Monday, November 23, 2020 1:41:42 AM(UTC)
iperione

Rank: Newbie

Groups: Registered
Joined: 10/11/2020(UTC)
Posts: 7
Italy
Location: rome

Ok Good news...

After a lot of attempts I found out the right configuration to stream on MainStreaming


Quality H264 1080p 3mbps AAC 128Kbps

Application FFMPEG



Video Bit Rates 3000 kbps size 1920x1080 Audio bit rate 128 kbps

Video
...
Profile Baseline
Level 3.1
Preset veryfast
Aspect.. Original

Audio
...
...

and this works!
DWAM  
#5 Posted : Monday, November 23, 2020 1:52:33 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,547
Man
France
Location: Bordeaux, France

Thanks: 212 times
Was thanked: 729 time(s) in 557 post(s)
These settings are very low and won't offer good quality. They do not even respect the H.264 recommendations... I suspect this platform does not offer quality services
iperione  
#6 Posted : Tuesday, November 24, 2020 6:14:40 AM(UTC)
iperione

Rank: Newbie

Groups: Registered
Joined: 10/11/2020(UTC)
Posts: 7
Italy
Location: rome

It is a nightmare...
These settings at the end weren't the solution.

Let me explain.

We were testing the streaming using obs studio, and when we stopped it, then we immediately started vmix streaming, and SBAM!!!
The streaming started, but, when we tryed again, stopping and restarting the streaming, the day after, with the same settings...
Nothing to do.
Doesn't work again!!

So we tryed again, and again, after we stopped OBS and quickly launced vmix streaming, everything worked fine.

Unbelievable.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.