logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
nakedeye  
#1 Posted : Tuesday, May 19, 2020 6:53:41 AM(UTC)
nakedeye

Rank: Advanced Member

Groups: Registered
Joined: 12/7/2017(UTC)
Posts: 35
Location: New Zealand

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Anyone had any luck getting NDI to work with AWS instances? Any help or pointers appreciated. I have two cloud based vMix switchers and am looking for a way to get NDI working between them.
mavik  
#2 Posted : Wednesday, May 27, 2020 3:00:25 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 331
Man
Location: Germany

Thanks: 2 times
Was thanked: 58 time(s) in 53 post(s)
Are they in the same VPC network and have the necessary ports open.
Alternatively you can use SRT.
Geoff B  
#3 Posted : Thursday, May 28, 2020 12:29:31 PM(UTC)
Geoff B

Rank: Member

Groups: Registered
Joined: 5/10/2020(UTC)
Posts: 17
Man
United States
Location: Sacramento, California

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
You'll need to open the have them in the same VPC, and open the correct ports in your security group. Also, you'll want to install NDI Tools on both instances and use Access Manager to add the IP addresses of your other instance(s).

thanks 1 user thanked Geoff B for this useful post.
CrimsonAvenger on 5/29/2020(UTC)
nakedeye  
#4 Posted : Friday, May 29, 2020 7:31:19 AM(UTC)
nakedeye

Rank: Advanced Member

Groups: Registered
Joined: 12/7/2017(UTC)
Posts: 35
Location: New Zealand

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Thanks guys! Yes both in the same VPC and confirmed by web controller working in both directions. Access manager crashes when I select New in the remote sources panel. NDI Tools on both servers.
CrimsonAvenger  
#5 Posted : Friday, May 29, 2020 4:41:39 PM(UTC)
CrimsonAvenger

Rank: Member

Groups: Registered
Joined: 5/28/2020(UTC)
Posts: 15
United Kingdom
Location: London

Thanks: 3 times
Nakedeye

I'm not sure if I'm doubling up on software running, but I got this working yesterday thanks to this thread and Geoff's response.

Windows Defender might be causing a problem. Try disabling app control.

Also, have you got enough RAM on the instances?

I tried this first with a t2.micro instance (no cost - free tier) and it ran like an old dog. That's just to drive NDI inject of Zoom/web browser. Not vMix obviously!

Changed to a t3a.medium and it was a breeze.
nakedeye  
#6 Posted : Wednesday, June 3, 2020 12:33:06 PM(UTC)
nakedeye

Rank: Advanced Member

Groups: Registered
Joined: 12/7/2017(UTC)
Posts: 35
Location: New Zealand

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Thanks for the post and glad you got it working. I am no closer to a resolution between my two server instances I have ports open and everything is on the same IP range and subnet. I can see each vMix systems web controller in the other server just no NDI. NDI Access manager crashes when trying to add external IP. The pop out panel doesn't show up and the main app screen just disappears.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.