logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
miguelcpal  
#1 Posted : Sunday, February 10, 2019 5:02:04 AM(UTC)
miguelcpal

Rank: Newbie

Groups: Registered
Joined: 2/10/2019(UTC)
Posts: 2
Spain

I've made an application that sends its content trough NDI. It has transparencies.

In OBS works well, but in vMix alpha channel appears as black. So I have to perform a luma key but the quality is much worse than in OBS because of the black borders of the luma key which do not appear in OBS.

In vMix, at the NDI input selection window, alpha channel is detected and represented as a gray checkerboard pattern. But, when selected, transparent areas appear as black.

¿Any solution to this?

admin  
#2 Posted : Sunday, February 10, 2019 5:55:27 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,165
Man
Location: Gold Coast, Australia

Was thanked: 2285 time(s) in 1016 post(s)
Hi,

vMix does fully supports alpha channel / transparency in NDI.
You mentioned seeing the checker-board pattern which seems to confirm it is working correctly.

You can now go ahead and use that input on top of another input, such as through the Overlay channel
to see the effect, but simply using that source by itself is naturally going to have a black background.

Regards,

Martin
vMix
zenvideo  
#3 Posted : Sunday, February 10, 2019 6:47:46 PM(UTC)
zenvideo

Rank: Advanced Member

Groups: Registered
Joined: 5/13/2014(UTC)
Posts: 347
Man
United Kingdom
Location: Manchester, UK

Thanks: 1 times
Was thanked: 140 time(s) in 94 post(s)
Originally Posted by: miguelcpal Go to Quoted Post
But, when selected, transparent areas appear as black.

The output of vMix has a default black background, so if you simply select a source with an alpha channel onto the Program output it will be self-keyed over that black background.
What happens if you use your NDI input as a layer in a Multiview, with at least one other source layer behind it? It should then be keyed using the alpha channel, as you are expecting.
miguelcpal  
#4 Posted : Sunday, February 10, 2019 7:27:01 PM(UTC)
miguelcpal

Rank: Newbie

Groups: Registered
Joined: 2/10/2019(UTC)
Posts: 2
Spain

In multiview, for instance, transparent areas appear as black and the background is not visible unless a luma key is set.

Solved:

I just deleted the configuration folders in AppData and now it works as expected.

I don't know if it was a Performance setting issue. Reseting the configuration solved the problem.

Thank you anyway.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.