logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
lfnobre  
#1 Posted : Tuesday, August 23, 2016 8:50:58 PM(UTC)
lfnobre

Rank: Newbie

Groups: Registered
Joined: 10/15/2015(UTC)
Posts: 9
Location: Calgary

Was thanked: 1 time(s) in 1 post(s)
Hello, I am having this trouble: Before launch the game, Desktop Capture works just fine. As soon as I launch the game, I cannot see in my production, the game that is running on the secondary machine.

Scenario 1 - vMix running on a desktop, Camera, USB microphone and Capturing via NDI, desktop capture running on a laptop (the game is running on the laptop as well)

Like I said, NDI input works just fine, but only until I launch the game. NDI continues to show the previous desktop, but never the game.

Scenario 2 - vMix running on a desktop with 4 monitors. Game deployed on monitor 1 and vMix app running on monitor 3. As son as I launch the game, I cannot control the mouse and continue using vMix. When I change the mouse from monitor 1 to any other monitor, the game goes minimized. When I bring the game back, vMix start showing in two monitors (split the app)

I need to record a video, playing the game in full screen, and put face camera on my son, so he can comment the game.

Please help.
admin  
#2 Posted : Tuesday, August 23, 2016 10:10:08 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,141
Man
Location: Gold Coast, Australia

Was thanked: 2239 time(s) in 1008 post(s)
Game capture is only supported on Windows 8.1 or higher, can you confirm, you have 8.1 or 10 installed?
lfnobre  
#3 Posted : Wednesday, August 24, 2016 1:46:34 AM(UTC)
lfnobre

Rank: Newbie

Groups: Registered
Joined: 10/15/2015(UTC)
Posts: 9
Location: Calgary

Was thanked: 1 time(s) in 1 post(s)
Windows 10 on all PCs
admin  
#4 Posted : Wednesday, August 24, 2016 3:45:34 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,141
Man
Location: Gold Coast, Australia

Was thanked: 2239 time(s) in 1008 post(s)
Hi,

For scenario 1, make sure vMix Desktop Capture for NDI is running using the Intel Graphics, rather than the Nvidia optimus.
If so it should say "DXGI" in grey letters in the bottom right hand corner of the desktop capture window which will allow capturing games.

For scenario 2, this is up to the game not taking over the mouse. See if the game can run in Windowed mode.
I would be cautious with trying to use vMix on the same system as a game however, as the game is going to try and use 100% of the graphics
making vMix drop in performance as a result.


Regards,

Martin
vMix
lfnobre  
#5 Posted : Wednesday, August 24, 2016 9:29:10 PM(UTC)
lfnobre

Rank: Newbie

Groups: Registered
Joined: 10/15/2015(UTC)
Posts: 9
Location: Calgary

Was thanked: 1 time(s) in 1 post(s)
Hi Martin, thanks for your reply. It worked when I tried on a different laptop, running vMix demo. On this laptop the DXGI it was there automatically. How can I set this?
By the way, I am loving vMix.
Tweak  
#6 Posted : Saturday, October 1, 2016 5:14:26 AM(UTC)
Tweak

Rank: Newbie

Groups: Registered
Joined: 10/1/2016(UTC)
Posts: 1

I am still having issues with this also.

I just upgraded my computer to windows 10 to get this working.

When I start vMix Desktop Capture for NDI 17.0.0.74 it says GDI on the bottom right. If I go to settings and uncheck use GPU Acceleration it doesn't save, and re-checks after pressing ok and checking settings again.

I have removed my NVIDIA GTX 980 TI completely from the system, and it has had the same issue using onboard intel graphics.

Please advise.

More info:

Games show up in windowed mode, but not full screen. I can only see the mouse, and hear sound.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.