Live Production Software Forums

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Thursday, September 27, 2012 3:54:16 AM(UTC)

Rank: Advanced Member

Groups: Registered
Joined: 8/23/2012(UTC)
Posts: 71
Location: Bangkok

Thanks: 1 times
Was thanked: 2 time(s) in 2 post(s)
OS Name Microsoft Windows 7 Ultimate
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name D-VA-HD64
I have just finished my new computer and am trying to get it all to work.

Here are first the details of the system

System Manufacturer Gigabyte Technology Co., Ltd.
System Model Sniper
System Type x64-based PC
Processor Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz, 3901 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F7, 5/31/2012
SMBIOS Version 2.7
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "6.1.7601.17514"
User Name D-VA-HD64\Rob
Time Zone Pacific Daylight Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.0 GB
Available Physical Memory 12.5 GB
Total Virtual Memory 29.9 GB
Available Virtual Memory 26.9 GB
Page File Space 15.0 GB
Page File C:\pagefile.sys

Name Intel(R) HD Graphics 4000
PNP Device ID PCI\VEN_8086&DEV_0162&SUBSYS_D0001458&REV_09\3&11583659&0&10
Adapter Type Intel(R) HD Graphics Family, Intel Corporation compatible
Adapter Description Intel(R) HD Graphics 4000
Adapter RAM (1,073,741,824) bytes
Installed Drivers igdumd64.dll,igd10umd64.dll,igd10umd64.dll,igdumd32,igd10umd32,igd10umd32
Driver Version
INF File oem44.inf (iIVBD0 section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 1920 x 1080 x 50 hertz
Bits/Pixel 32
Memory Address 0xF7400000-0xF77FFFFF
Memory Address 0xD0000000-0xDFFFFFFF
I/O Port 0x0000F000-0x0000F03F
IRQ Channel IRQ 4294967290
I/O Port 0x000003B0-0x000003BB
I/O Port 0x000003C0-0x000003DF
Memory Address 0xA0000-0xBFFFF
Driver c:\windows\system32\drivers\igdkmd64.sys (, 14.06 MB (14,745,600 bytes), 3/20/2012 1:32 PM)

Name AMD Radeon HD 7800 Series
PNP Device ID PCI\VEN_1002&DEV_6819&SUBSYS_04311043&REV_00\4&B77C4C1&0&0008
Adapter Type AMD Radeon Graphics Processor (0x6819), Advanced Micro Devices, Inc. compatible
Adapter Description AMD Radeon HD 7800 Series
Adapter RAM (2,147,483,648) bytes
Installed Drivers aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver Version 8.982.0.0
INF File oem47.inf (ati2mtag_R575B section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 1280 x 1024 x 75 hertz
Bits/Pixel 32
Memory Address 0xE0000000-0xEFFFFFFF
Memory Address 0xF7CC0000-0xF7CFFFFF
I/O Port 0x0000DF00-0x0000DFFF
IRQ Channel IRQ 4294967287
Driver c:\windows\system32\drivers\atikmpag.sys (, 360.00 KB (368,640 bytes), 7/28/2012 8:14 AM)

Here are my first observations:

I have the external recorder switched ON upon startup.
LCD TV via HDMI connected to HD7850 card.
Sound is also via this LCD monitor

Using a prerecorded video input on the decklinkduo,the image and sound is in sync upon startup from the input via Decklink Video Capture, Audio device Decklink Audio capture. (this is the first channel)
I have also an sdi monitor on the Decklink output #2, the video is playing back but no audio.
I do not find a suitable option to make the sound work via the ExternaL
But by changing the options the program frequently stops working and generates this log:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: vmix2012x64.exe
Problem Signature 02:
Problem Signature 03: 503af826
Problem Signature 04: vMix2012
Problem Signature 05:
Problem Signature 06: 503af826
Problem Signature 07: 3f5
Problem Signature 08: 5e
Problem Signature 09: System.NullReferenceException
OS Version: 6.1.7601.
Locale ID: 1033

So that is the first issue/question:
how do I get sound on both HDMI and SDI output via the Deckling output no2

Then I recorded the slip with the codec Decklink MJPEG Compressor and this seems to work, no dropped frames.
However, if I want to play back this file, via add input, i get an error:
The operation cannot be performed because the pins are not connected.

There seems to be no appropriate Codec available.
The file is recorded, I find in the designated folder the file at 500 mb, however it will not load and also VLC is not able to play back as it is "damaged" I can choose "Play as is" but that shows only the first frame as still, while the timeline is moving.
all this time I am running the x64 version

Then I tried the normal 32 bit vMix version: suddenly I have sound in sinc on both screens (hdmi and sdi), with minimal delay (slight echo)

Recording with Blackmagic MJPEG compressor or the 8bit MJPEG Codec does 2 things:
the sound becomes "broken" irregular, the moment the rec button is pressed, then stops completely on hdmi and sdi when rec is stopped.
Only reload of the input will correct it.

Again, the file is there, but cannot be opened, with the same error message as with the x64 version.

Then I tried to record via the multicorder and this seems to weork: the generated file also shows now a real thumbnail, instead of the VLC cone. Playback works as well, however, no sound is recorded with the image, so it seems.

VLC confirms that there is no sound within this file.
Checking the other files that do not show a thumbnail I notice that there is broken sound, with a single first frame only. it also seems to be faster than the original.

OK, this was the first test and i hope that you can help me further with it.

Best wishes.


PS., Martin , I followed your advice and rebooted several times, that did not help. then i un installed the BMD drivers and after restart installed again. issues remain.

#2 Posted : Thursday, September 27, 2012 5:54:38 AM(UTC)

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,165
Location: Gold Coast, Australia

Was thanked: 4179 time(s) in 1499 post(s)
What audio device have you selected when recording to MJPEG?
Also under External Output settings what is Input Audio Device set to?

These should both be set to "vMix Audio"


#3 Posted : Friday, September 28, 2012 12:56:40 AM(UTC)

Rank: Advanced Member

Groups: Registered
Joined: 8/23/2012(UTC)
Posts: 71
Location: Bangkok

Thanks: 1 times
Was thanked: 2 time(s) in 2 post(s)
Martin, there are 2 options for the audio devise :
Audio Device
Input Audio Device

the second option has the vMix Audio

the first has a whole range of confusing options;
Default DirectSound Device
DirectSound 1: tOSHIBA tv
dIRECTsOUND : spdif-OUT (soundblaster Recon3Di
DirectSound Speakers (2- Blackmagic Audio)
DirectSound Speakers (blackmagic Audio)
DirectSound Speakers (Sound Blaster Recon 3Di

Any suggestion?
For now I have set it up as per your suggestion and ..... it works!

still a lot to figure out, i am sure!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.