logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
ADM  
#1 Posted : Wednesday, February 21, 2024 9:50:49 PM(UTC)
ADM

Rank: Newbie

Groups: Registered
Joined: 1/31/2023(UTC)
Posts: 6
United Kingdom

Here's our current puzzle.

We operate a high end Dell PC on a dedicated 500Mbps fibre line. It runs Teams (currently "classic Teams") and vMix on the same device.
We note that when we add NDI inputs from the Teams call, rather than the audio being captured from the individual participants, the audio is the mixed "active speaker" audio.

I've been testing on other devices and sometimes the audio is correctly isolated, and sometimes it isn't, so the device itself isn't the issue. Also I have tried on two different accounts, meaning that the Teams account isn't the issue. We are currently runnning v26.

Any ideas what could define which audio channel is ingested by vMix?
dmwkr  
#2 Posted : Wednesday, February 21, 2024 10:26:12 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 529

Thanks: 62 times
Was thanked: 125 time(s) in 114 post(s)
Per Microsoft's description of the NDI-out features:

"The incoming audio for a meeting is mixed together and will be the same for all individual user streams."

https://support.microsof...9-4dca-a2cd-07181276afa3
ADM  
#3 Posted : Wednesday, February 21, 2024 10:35:09 PM(UTC)
ADM

Rank: Newbie

Groups: Registered
Joined: 1/31/2023(UTC)
Posts: 6
United Kingdom

thanks, that's extremely weird as it isn't always the case. So it seems like the isolated audio is pure luck. How very microsoft.
Hypohamish  
#4 Posted : Saturday, February 24, 2024 7:18:25 AM(UTC)
Hypohamish

Rank: Advanced Member

Groups: Registered
Joined: 12/19/2020(UTC)
Posts: 54
United Kingdom
Location: London

Thanks: 2 times
Was thanked: 3 time(s) in 3 post(s)
Are you ticking the box that says Isolated Audio?


In the teams settings (outside of a meeting)


Top right > settings > app permissions


Then production capabilities, you can not only turn on NDI, but turn on Isolated Audio.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.