logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Rehan  
#1 Posted : Thursday, July 10, 2014 4:30:00 PM(UTC)
Rehan

Rank: Advanced Member

Groups: Registered
Joined: 12/29/2013(UTC)
Posts: 54
Location: Mississauga, Canada

Thanks: 10 times
Was thanked: 3 time(s) in 3 post(s)
When I have vMix at NTSC 60i/30p and launch FMLE for streaming, the CPU usage stays around 10% for the duration of the broadcast (usually a couple hours).

When I have vMix at NTSC 60p, the CPU usage for FMLE starts off low but then rises to 50% or more within a minute and stays high. The only change is that vMix has been switched to NTSC 60p.

The PC has an i7-4770 processor and Nvidia GTX 660 video card. vMix Video Device output resolution is 854x480, which is the same as the FMLE streaming resolution.

What would be causing this big difference in CPU usage?
richardgatarski  
#2 Posted : Thursday, July 10, 2014 5:22:39 PM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,475
Location: Stockholm

Thanks: 116 times
Was thanked: 229 time(s) in 192 post(s)
my guess is that going from 30p to 60p will indeed imply a significant increase in CPU usage. But perhaps not 40 percentage points.

Have you set the External frame rate (and resolution) to the same as vMix's general?
Rehan  
#3 Posted : Friday, July 11, 2014 2:46:42 AM(UTC)
Rehan

Rank: Advanced Member

Groups: Registered
Joined: 12/29/2013(UTC)
Posts: 54
Location: Mississauga, Canada

Thanks: 10 times
Was thanked: 3 time(s) in 3 post(s)
richardgatarski wrote:
my guess is that going from 30p to 60p will indeed imply a significant increase in CPU usage. But perhaps not 40 percentage points.

Have you set the External frame rate (and resolution) to the same as vMix's general?

For external frame rate, I've tried both 30fps (to match FMLE) and 60fps (to match vMix system) and it didn't make much of a difference. In both cases, vMix still uses very little CPU -- typically around 5% or less. It's only FMLE's CPU usage that jumps up when I increase the frame rate in vMix.
Maximus  
#4 Posted : Friday, July 11, 2014 8:12:44 PM(UTC)
Maximus

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2012(UTC)
Posts: 127
Location: Barbados

Thanks: 1 times
Was thanked: 17 time(s) in 17 post(s)
If you are inputting 60fps and outputting 30fps or any other frame rate, FMLE will have to do much more work and consume lots of CPU. If the input and output match, then FMLE consumes much less CPU. When I input 1080 and output 720, my CPU goes from around 35% to 90+%, If I input 720 and output 720, CPU stays around 30-35%.

That has been my observation.

Yours may vary
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.