logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
MarkNF82  
#1 Posted : Monday, August 22, 2022 2:05:05 AM(UTC)
MarkNF82

Rank: Advanced Member

Groups: Registered
Joined: 12/16/2018(UTC)
Posts: 59
Canada
Location: Newfoundland & Labrador

Thanks: 1 times
Was thanked: 5 time(s) in 3 post(s)
Hi Everyone,

Having some issues with titles based on data sources. Randomly the titles will skip one and display the data from the data sources row 2 down instead of the next one. This is very annoying when trying to display hymn lyrics or other speeches live. I have 2 shortcuts made (DataSourcesNextRow & DataSourcesPreviousRow) so I follow the script that way. For the times it happens, I quickly go previous row, then next row again and it's fine again.


Although I have not had the datasources list on the screen when it happens, I don't think the wrong datasourcesrow is being selected. If that was the case, I would have to go back 2 rows instead of just just the 1 I would think?

I thought cycling through the titles before going live, but that doesn't seem to help.

Any one else have this issue?

I am using LibreCalc with an Excel (97-2003) formatted spreadsheet on the same computer with vMix.
vMix 24.0.0.72.


doggy  
#2 Posted : Monday, August 22, 2022 3:09:39 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 4,221
Belgium
Location: Belgium

Thanks: 244 times
Was thanked: 758 time(s) in 618 post(s)
Originally Posted by: MarkNF82 Go to Quoted Post


Although I have not had the datasources list on the screen when it happens, I don't think the wrong datasourcesrow is being selected. If that was the case, I would have to go back 2 rows instead of just just the 1 I would think?


You should , is part of finding where an issue is !

Quote:

Any one else have this issue?


Never


Are you just using mentioned shortcuts to advance the rows ? with your keyboard or other controller ?

MarkNF82  
#3 Posted : Monday, August 22, 2022 3:27:50 AM(UTC)
MarkNF82

Rank: Advanced Member

Groups: Registered
Joined: 12/16/2018(UTC)
Posts: 59
Canada
Location: Newfoundland & Labrador

Thanks: 1 times
Was thanked: 5 time(s) in 3 post(s)
I'll try and find another monitor and leave the datasources window open all the time and try that out.

Originally I started out with just the keyboard for shortcuts. Later I got an XK-24 and finally a streamdeck. The issue has happened with all of them.

Also, all the titles come from different sheets of the same file. I'll try separating them and see if that helps.


Thanks
OldDesertLizard  
#4 Posted : Monday, August 22, 2022 3:59:35 AM(UTC)
OldDesertLizard

Rank: Newbie

Groups: Registered
Joined: 9/5/2021(UTC)
Posts: 6
Man
United States

Are you getting this consistently on one particular line in your data source? Or pretty much infrequently but on random data source lines?

I've been using self-developed GT Titles with Excel spreadsheets as data sources now for a year or more. I've got a 32-button StreamDeck (without Companion or any other add-on other than vMix) with Previous and Next buttons, tied to an event-specific spreadsheet (I've been creating an event-specific Preset for each client event). I've had this issue happen only a couple of times.

Here's what I discovered: My button press technique was the problem. I tended to "lean in" to the button press, which I believe was causing the StreamDeck to perceive multiple presses. I've "relearned" to just tap... and be sure to tap "all the way through", since on occasion I think I was fearful of causing a double-tap and didn't go down far enough to make good contact at the bottom of the button travel. I can't recall having this issue in a long time now.

Your issue might be different...just offering my experience.
Javeer  
#5 Posted : Friday, August 26, 2022 10:52:52 AM(UTC)
Javeer

Rank: Newbie

Groups: Registered
Joined: 6/15/2021(UTC)
Posts: 5
United Kingdom
Location: Middlesex

Was thanked: 1 time(s) in 1 post(s)
similar to OldDesertLizard - I've experienced the issue a couple of times.

I also found it was a result of repeated presses due to lag. For instance, I would of pressed nextItem shortcut key but something caused a delay which would then have me press it again cos I didn't want to miss timings by so much and then that caused a double skip.

That all said, try checking the ADVANCED section of your SHORTCUT to see if there is anything set there accidently.
Also check if you have multiple functions listed on a specified KEYBOARD BUTTON which could be doubling up the action.
You could check in the inputs TRIGGERS option for anything.

MarkNF82  
#6 Posted : Sunday, September 11, 2022 1:19:04 AM(UTC)
MarkNF82

Rank: Advanced Member

Groups: Registered
Joined: 12/16/2018(UTC)
Posts: 59
Canada
Location: Newfoundland & Labrador

Thanks: 1 times
Was thanked: 5 time(s) in 3 post(s)
Hi Everyone,

Fortunately I was able to take a screenshot of it happening. It does not look to be a shortcut problem.

In the photo, the source row is clearly selected as row 14 "Seek Ye First The Kingdom", but what is actually displayed on the lower third is "Faith of Our Fathers", which is on row 9. This happens randomly. Some weeks it will not happen at all, while other times it will happen multiple times, so I have to be ready to take out the graphic at any time. This affects our script, hymn lyrics and lower third titles.

For compatibility, I am using LibreCalc with an excel 97-2003 spreadsheet. I will try a different format when I get a chance if recommended.


vMix 24.0.0.72.
LibreOffice 7.1.5.2
Windows 10 - 21H2 - 19044.1889


title problems.jpg (78kb) downloaded 1 time(s).
doggy  
#7 Posted : Sunday, September 11, 2022 2:17:20 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 4,221
Belgium
Location: Belgium

Thanks: 244 times
Was thanked: 758 time(s) in 618 post(s)
Just did an event handling over 1600 data rows total with not one wrong row displayed ( except from me telling it to inadvertently)

What is your actual shortcut/function setting to change the row ?

Else advice to contact vMix support
dmwkr  
#8 Posted : Wednesday, September 21, 2022 7:23:29 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 385

Thanks: 51 times
Was thanked: 88 time(s) in 78 post(s)
To my knowledge, this happens when you have sorted the columns by clicking on the title of one of the columns in vMix. One rule I strictly follow: Never sort the columns in vMix.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.