logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Peter from Sweden  
#1 Posted : Wednesday, August 24, 2022 12:41:44 AM(UTC)
Peter from Sweden

Rank: Newbie

Groups: Registered
Joined: 8/24/2022(UTC)
Posts: 4
Sweden

I have a high end PC and recording with latest updated vMix (vMix 4K - 24.0.0.72 x64) for years using USB Capture HDMI as input.

I have tested this two units as input:
Magwell USB Capture HDMI (used for years with no problem)
Ezcap USB 3.0 SDI Capture (new)

With HDMI capture input, the records is smooth, all fine (I've used this several years with no problem).
But when I record with Instant Replays using the new SDI capture input, the Instant record freezes every 2-3 seconds (on playback it shows 2-3 seconds play, freezes 1 second, continue playing 2-3 seconds, freezes 1 second... and so on).
I have tried different resolutions and FPS, no difference, it freezes with SDI, not with HDMI.

Recording is made with only one camera and with one capture unit at a time.
The ususal "live" recording (the Record button, at the bottom on vMix) is smooth with both HDMI and SDI.

The vMix preset is the same with both units (I only change input for cam capture), the problem only occurs with SDI.

I really appreciate any help with this. Is it a vMix bug?
IceStream  
#2 Posted : Wednesday, August 24, 2022 9:08:40 PM(UTC)
IceStream

Rank: Advanced Member

Groups: Registered
Joined: 3/7/2012(UTC)
Posts: 2,500
Man
Location: Canada

Thanks: 32 times
Was thanked: 478 time(s) in 449 post(s)
@ Peter from Sweden

If the Magewell works but the Ezcap doesn't, then it is likely the device itself, its compatibility with your system or a problem with the SDI feed or connection.
Are you able to check the SDI connection with either another SDI camera, cable or capture device?
Unfortunately, the Ezcap devices are not listed on the vMix Website as "tested" and supported devices and as such are a "use at your own risk" product, which my gut tells me will probably not work well with vMix.


Ice
Peter from Sweden  
#3 Posted : Wednesday, August 24, 2022 10:07:17 PM(UTC)
Peter from Sweden

Rank: Newbie

Groups: Registered
Joined: 8/24/2022(UTC)
Posts: 4
Sweden

Originally Posted by: IceStream Go to Quoted Post
@ Peter from Sweden

If the Magewell works but the Ezcap doesn't, then it is likely the device itself, its compatibility with your system or a problem with the SDI feed or connection.
Are you able to check the SDI connection with either another SDI camera, cable or capture device?
Unfortunately, the Ezcap devices are not listed on the vMix Website as "tested" and supported devices and as such are a "use at your own risk" product, which my gut tells me will probably not work well with vMix.


Ice



Thank you for the answer!

I had the suspicions that if the device is not in the "supported devices" list, that might be the reason. What I find strange is that it records without a problem (recording setup is 1920x1080/50p, MP4/H264high and Hardware encoder enabled). Why no problem there, but problem on Instant Replay?

Even if I record with Instant Replay only, the freezes appears (it happens on the recording; if I replay it, the freezes appears in exactly same places).

Does it have anything to do with codecs for Instant Replay recording? Where can I change the codec for this?
I don't have another SDI camera, SDI cable or SDI capture device.

dmwkr  
#4 Posted : Wednesday, August 24, 2022 11:47:43 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 397

Thanks: 51 times
Was thanked: 91 time(s) in 81 post(s)
Can't answer your questions, but what you could try as a (non-perfect) workaround, is route your Ezcap input to one of the Outputs 2-4 and use that Output as a camera on the Instant Replay. Maybe it narrows down the source of the problem.
Peter from Sweden  
#5 Posted : Thursday, August 25, 2022 12:14:48 AM(UTC)
Peter from Sweden

Rank: Newbie

Groups: Registered
Joined: 8/24/2022(UTC)
Posts: 4
Sweden

Originally Posted by: dmwkr Go to Quoted Post
Can't answer your questions, but what you could try as a (non-perfect) workaround, is route your Ezcap input to one of the Outputs 2-4 and use that Output as a camera on the Instant Replay. Maybe it narrows down the source of the problem.


I could try that. Thank you!
I will report the outcome later :-)
Peter from Sweden  
#6 Posted : Tuesday, September 6, 2022 1:01:50 AM(UTC)
Peter from Sweden

Rank: Newbie

Groups: Registered
Joined: 8/24/2022(UTC)
Posts: 4
Sweden

Originally Posted by: Peter from Sweden Go to Quoted Post
Originally Posted by: dmwkr Go to Quoted Post
Can't answer your questions, but what you could try as a (non-perfect) workaround, is route your Ezcap input to one of the Outputs 2-4 and use that Output as a camera on the Instant Replay. Maybe it narrows down the source of the problem.


I could try that. Thank you!
I will report the outcome later :-)



I've tested this: With SDI output on camera (with Ezcap), I routed that as source for Instant Replay (via NDI). No freeze problem, that's good.
But I noticed the Ezcap SDI was a bit slow for 50 fps (blurry objects when moving camera). Don't know if it was the Ezcap itself (crap?) or the SDI output on the camera that was "too slow".
dmwkr  
#7 Posted : Tuesday, September 6, 2022 7:53:50 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 397

Thanks: 51 times
Was thanked: 91 time(s) in 81 post(s)
No need for NDI here, you can route an input directly to one of the outputs by selecting the camera input as the source. (https://www.vmix.com/help25/SettingsOutputs.html) If it's working, fine, but will probably need more resources via NDI.

Don't know the Ezcap, don't even know the name of you camera. Can it really output 1080p50 via SDI? Do you have a control monitor with SDI in to check the output? Use a different software (OBS) to see if it is a vMix compatibility issue.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.