vMix - Live Production Software
Live Production Software Forums       www.vmix.com
Welcome Guest Search | Active Topics | Log In | Register

Untag as favorite
vMix call: Elegant way to avoid sending studio audio back to the studio?
niemi
#1 Posted : Monday, 11 September 2017 11:13:53 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 16/02/2017
Posts: 62
Location: Denmark

Thanks: 11 times
Was thanked: 4 time(s) in 4 post(s)
When setting up a vMix project with a vMix call guest we have had som issues with the studio hosts hearing themselves. The studio's audio comes via embedded SDI into vMix via a SDI2 on Decklink card.

The reporter on the vMix call will now hear this audio.

But the studio's audio will also be played back via External 1 to the studio via SDI1 on the same Decklink card. Now the hosts in the studio will hear themselves with maybe 200ms echo.

To fix, under Options > Audio Outputs, I have set "A" to "Speakers (Blackmagic DeckLink Duo 2 (1) Audio)" and "B" to "Speakers (Blackmagic DeckLink Duo 2 (2) Audio)".

Then I set the vMix call's audio mixer to "A" and disable "M". Now only the sound of the vMix call reporter is routed to audio bus A, and only that is sent to the studio.

Then I set the Decklink Duo (2)'s audio mixer to "B" and disable "M". Only audio from the studio is now routed to bus B. After right-clicking the vMix call, I have set the "Audio Source" to bus B.

The sound is now correctly set up, even without sending anything to "External".

However, I need to also send the video to the studio, so I activate "External" which I set to only send video to Decklink 2 Duo (1) 1 and setting the "Audio Channels" to "Master". Nothing is sent to master, so this prevents the audio from being sent twice.

This at least works, but doesn't feel like the right configuration.

What do you do when working with a studio < > reporter setup like this?

IceStream
#2 Posted : Tuesday, 12 September 2017 12:43:24 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 7/03/2012
Posts: 1,947
Location: Canada

Thanks: 24 times
Was thanked: 335 time(s) in 319 post(s)
@ niemi

Have you tried turning down the "Headphone" volume knob of the Studio Audio Input?


Ice
niemi
#3 Posted : Tuesday, 12 September 2017 2:10:30 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 16/02/2017
Posts: 62
Location: Denmark

Thanks: 11 times
Was thanked: 4 time(s) in 4 post(s)
IceStream wrote:
@ niemi

Have you tried turning down the "Headphone" volume knob of the Studio Audio Input?


Ice


Hey Ice, only "Master" has a headphone knob.

See the screenshot below which is also the audio settings for the current project.

IceStream
#4 Posted : Tuesday, 12 September 2017 2:23:11 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 7/03/2012
Posts: 1,947
Location: Canada

Thanks: 24 times
Was thanked: 335 time(s) in 319 post(s)
@ niemi

Click the cog wheel of actual Input of the Studio Audio {I'm guessing the Decklink Duo (2)}


Ice
niemi
#5 Posted : Tuesday, 12 September 2017 3:55:55 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 16/02/2017
Posts: 62
Location: Denmark

Thanks: 11 times
Was thanked: 4 time(s) in 4 post(s)
IceStream wrote:
@ niemi

Click the cog wheel of actual Input of the Studio Audio {I'm guessing the Decklink Duo (2)}


Ice


I took a look and it's there, turned all the way up.

Do you think turning it down would do it?
IceStream
#6 Posted : Tuesday, 12 September 2017 9:10:34 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 7/03/2012
Posts: 1,947
Location: Canada

Thanks: 24 times
Was thanked: 335 time(s) in 319 post(s)
@ niemi

Yes, turning the headphone knob down will prevent that Input from playing on your PC speakers (or headphones) but still send the signal to Master Output.


Ice
niemi
#7 Posted : Tuesday, 12 September 2017 4:17:58 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 16/02/2017
Posts: 62
Location: Denmark

Thanks: 11 times
Was thanked: 4 time(s) in 4 post(s)
IceStream wrote:
@ niemi

Yes, turning the headphone knob down will prevent that Input from playing on your PC speakers (or headphones) but still send the signal to Master Output.


Actually I would like to still hear audio coming from the studio (Decklink Duo (2) in my vMix-connected headphones, I just don't want to send that audio back to studio together with the reporter's audio (Call San Fran 1).

I want to only send the reporter's audio (Call San Fran 1) back to the studio on (Decklink Duo (1).

This is actually how it works now, but I believe the setup is not quite right as I'm sending the audio as soon as the vMix-project is opened, because I've set "A" to Speakers (Blackmagic DeckLink Duo 2 (1) and "B" to Speakers (Blackmagic DeckLink Duo 2 (1).

This means that I send audio but no video. If I want to send video I have to use external, but I cannot re-send audio A and B again as this will also create and echo. So I've picked master here, as nothing is being sent to master.

However this also means that I won't hear the two incoming sources in my headphones, which is not ideal either.
IceStream
#8 Posted : Wednesday, 13 September 2017 3:03:25 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 7/03/2012
Posts: 1,947
Location: Canada

Thanks: 24 times
Was thanked: 335 time(s) in 319 post(s)
@ niemi

Ah, I understand.
If your original mix-minus studio monitoring works, then I would suggest going with that. It might not be elegant, but if it's working, then it's probably "right"!


Ice
niemi
#9 Posted : Wednesday, 13 September 2017 8:18:22 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 16/02/2017
Posts: 62
Location: Denmark

Thanks: 11 times
Was thanked: 4 time(s) in 4 post(s)
Thanks Ice, I agree. It really worked like a charm yesterday.

Now I just need to work with the details so that:

1) Audio bus A is first sent when hitting External (right now it is being sent with just vMix opened)
2) I can hear both audio bus A and B in headset connected to vMix
DWAM
#10 Posted : Wednesday, 13 September 2017 9:46:45 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 20/03/2014
Posts: 1,509
Location: Bordeaux, France

Thanks: 115 times
Was thanked: 391 time(s) in 316 post(s)
Hi Niemi

did you check this audio setup I suggested before?

https://forums.vmix.com/...spx?g=posts&t=10740

Guillaume
niemi
#11 Posted : Wednesday, 20 September 2017 5:21:43 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 16/02/2017
Posts: 62
Location: Denmark

Thanks: 11 times
Was thanked: 4 time(s) in 4 post(s)
DWAM wrote:
Hi Niemi

did you check this audio setup I suggested before?

https://forums.vmix.com/...spx?g=posts&t=10740

Guillaume

Hi Guillaume, I will take a look at that, thank you.

In the meantime I talked to Jens at IBC, and the solution is pretty simple as he pointed out:

SOLUTION

Don't set outputs "A" to a device like "Speakers (Blackmagic DeckLink Duo 2 (1) Audio)".

Instead simply set it to "Enabled". This option is listed in the dropdown together with the devices and appears in the middle of the list, so it is easily overlooked.

With audio bus A simply enabled, I can now send both video and audio (vMix call) with "External" where audio is set to Bus A.

This was what I wanted to archive.
DWAM
#12 Posted : Wednesday, 20 September 2017 7:57:22 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 20/03/2014
Posts: 1,509
Location: Bordeaux, France

Thanks: 115 times
Was thanked: 391 time(s) in 316 post(s)
Hi Niemi

the solution I gave also takes advantage of the "enabled" feature as well as using a routing solution for PA monitoring in a studio.
Good to know Jens could help meanwhile btw...

Bien à toi
Guillaume
Users browsing this topic
Guest
Untag as favorite
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAFPro Theme Created by Jaben Cargman (Tiny Gecko)
Powered by YAF | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 0.053 seconds.