logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
FBCAV  
#1 Posted : Monday, April 10, 2017 7:46:52 PM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

Hi folks,
First post here, been playing around with Vmix on and off for a bit and went for it this month for streaming church services. Previously we used Wirecast Play with Youtube and we've now switched to Sunday Streams with Vmix and simultaneous streaming to Youtube as well.

The issue I'm having is that our Youtube stream is now hit or miss with quality. Whereas we streamed to Youtube with Wirecast Play at 720p30/2.5Mbps and we saw 720p available on Youtube, we are now streaming at 720p30/1.5Mbps with Vmix along with 360p/500Mbps, however, Youtube typically only sees the 360p feed. Sometimes it gets the 720p feed, but I haven't been able to determine how to ensure it gets the 720p feed only.

Of the two selections in the stream settings, one is Sunday Streams' multibitrate rtmp stream and the other is Youtube's rtmp stream. The 3rd is not used.

Thanks,
Jeff

Jeff Klein, DMC-E
Head Volunteer Sound Geek
Faith Baptist Church
Glen Burnie, Maryland
(Website / Twitter)
http://www.faithbc.net / @FBC_TechTeam

"Clothe yourselves, all of you, with humility toward one another, for God opposes the proud but gives grace to the humble." 1 Peter 5:5
DWAM  
#2 Posted : Tuesday, April 11, 2017 1:49:11 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,721
Man
France
Location: Bordeaux, France

Thanks: 243 times
Was thanked: 791 time(s) in 589 post(s)
Hi Jeff and welcome to the vMix community

Youtube is a multiscreen transcoding platform: it means you don't have to push multiple streams to get multiple resolutions.

You should only send one stream to YT being the best possible quality: I'd suggest 720p30 at 4Mbits or more if you can. YT will then transcode it to 720p, 480p, 360p, 240p and 144p.

Guillaume
FBCAV  
#3 Posted : Tuesday, April 11, 2017 9:10:30 AM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

DWAM wrote:
Hi Jeff and welcome to the vMix community


Thanks :)

Quote:
Youtube is a multiscreen transcoding platform: it means you don't have to push multiple streams to get multiple resolutions.

You should only send one stream to YT being the best possible quality: I'd suggest 720p30 at 4Mbits or more if you can. YT will then transcode it to 720p, 480p, 360p, 240p and 144p.

Guillaume


Hi Guillaume,
Yes, that is what we initially did with Wirecast Play / Youtube Live, which didn't have/need a multistream option. We just put in the Youtube Live steam info and used the recommended Youtube setting preset (720p30/~2.5Mbps) and it did as you say.

With Vmix, we are now sending to SundayStreams' multibitrate stream with the Custom RTMP setting, so we select two bit rate settings in the Streaming Quality setup window under configuration 1 (of whatever those 1, 2 and 3 buttons under Profile are called). Config 2 we also have set to the same stream settings as we did in Wirecast Play for simultaneous streaming to Youtube Live with the Youtube preset.

Here's the issue...the Streaming Quality settings window appears to affect both presets in the Profile. I thought that we could set the multiple bitrates for the SundayStreams setting under the config 1 button and the single 720p bitrate for Youtube under the config 2 button, but when I switched back to the SundayStreams config, it now was only set to 720p as well (i.e. when I unchecked 360p for Youtube, it was unselected for everything in the Profile).

So, we reselected the dual bitrate settings so SundayStreams would get both qualities, but for some reason Youtube varies whether it will grab the 360p feed or the 720p feed.

Any idea how I can set it up for 2 bitrates to SundayStreams and one to Youtube Live?

Thanks,
Jeff
sinc747  
#4 Posted : Tuesday, April 11, 2017 12:01:06 PM(UTC)
sinc747

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 984
Man
United States
Location: Fairhope, Alabama USA

Thanks: 498 times
Was thanked: 191 time(s) in 157 post(s)
@Jeff

vMix will stream to three different destination CDN's. So, why not stream to #1 to YouTube, and then #2 and #3 at different bit rates/resolutions to Sunday Streams?

- Tom
FBCAV  
#5 Posted : Tuesday, April 11, 2017 12:32:00 PM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

sinc747 wrote:
@Jeff

vMix will stream to three different destination CDN's. So, why not stream to #1 to YouTube, and then #2 and #3 at different bit rates/resolutions to Sunday Streams?

- Tom


Hi Tom,
Because the Stream Quality Settings are the same for all 3 streaming destinations in that case as well and no matter if I send 2 separate bitrate streams or a single multi-bitrate stream to Sunday Streams, I have to have both of the bitrate quality selections set in Stream Quality Settings, and Youtube seems to only lock on the 360p lower quality stream and ignores the 720p stream.

Does that make sense? Hopefully I'm explaining this correctly. If I could just force Youtube to ignore the 360p stream and lock into the 720p stream, that would do the trick I would think.

Thanks,
Jeff
FBCAV attached the following image(s):
Streaming Quality Settings.png (18kb) downloaded 1 time(s).
Streaming Settings.png (17kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
ask  
#6 Posted : Tuesday, April 11, 2017 6:29:07 PM(UTC)
ask

Rank: Advanced Member

Groups: Registered
Joined: 10/13/2012(UTC)
Posts: 1,153
Australia
Location: Melbourne

Thanks: 210 times
Was thanked: 196 time(s) in 179 post(s)
OK. The solution here is to run multiple instances of vMix. Go the the settings menu and turn on advanced settings. Then Enable multilpe instances on the Options page. Open two instances of vMix making sure you have turned on the NDI optings in the External settings. On the second instance of vMix bring in an NDI input of whichexver feed you want to send. (usually the Output) and setup your stream settings to you prefered CDN. Start the stream on both instances. Simple as that.
FBCAV  
#7 Posted : Tuesday, April 11, 2017 9:45:15 PM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

ask wrote:
OK. The solution here is to run multiple instances of vMix. Go the the settings menu and turn on advanced settings. Then Enable multilpe instances on the Options page. Open two instances of vMix making sure you have turned on the NDI optings in the External settings. On the second instance of vMix bring in an NDI input of whichexver feed you want to send. (usually the Output) and setup your stream settings to you prefered CDN. Start the stream on both instances. Simple as that.


Would the CPU load be the same with 2 instances running for each bit rate than one instance with multiple bit rates?


Thanks,
Jeff
ask  
#8 Posted : Wednesday, April 12, 2017 9:46:08 PM(UTC)
ask

Rank: Advanced Member

Groups: Registered
Joined: 10/13/2012(UTC)
Posts: 1,153
Australia
Location: Melbourne

Thanks: 210 times
Was thanked: 196 time(s) in 179 post(s)
I believe so.
Amokka  
#9 Posted : Monday, April 17, 2017 1:05:18 PM(UTC)
Amokka

Rank: Advanced Member

Groups: Registered
Joined: 4/6/2016(UTC)
Posts: 84
Man
Location: Sweden

Thanks: 27 times
Was thanked: 19 time(s) in 14 post(s)
I was testing use of 2 instances a while ago.

I definitely had additional CPU load when linking two instances of vMix using NDI.
if you are currently well within your hardware's capabilities, you will *probably* not get into trouble adding the second instance.
sinc747  
#10 Posted : Tuesday, April 18, 2017 12:10:00 AM(UTC)
sinc747

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 984
Man
United States
Location: Fairhope, Alabama USA

Thanks: 498 times
Was thanked: 191 time(s) in 157 post(s)
FBCAV wrote:
Because the Stream Quality Settings are the same for all 3 streaming destinations in that case as well and no matter if I send 2 separate bitrate streams or a single multi-bitrate stream to Sunday Streams, I have to have both of the bitrate quality selections set in Stream Quality Settings, and Youtube seems to only lock on the 360p lower quality stream and ignores the 720p stream.

Does that make sense? Hopefully I'm explaining this correctly. If I could just force Youtube to ignore the 360p stream and lock into the 720p stream, that would do the trick I would think.

Thanks,
Jeff


Sometimes I'm really dense, but that doesn't make sense to me. If you send YouTube one 720p stream, they will transcode it to 720, 480, 360, 240 and 144 and make that available to your viewer. Seems for some folks that YouTube will auto select the resolution based on the viewer's bandwidth. In other cases, the viewer gets whatever their device's default resolution is. Either way the viewer can select any of the resolutions assuming his bandwidth will support it.

Now, in your example the Stream Quality settings window for Sunday Streams 0930 Service shows a single quality setting (like H264 Multi Bitrate 720p 1.5mbps AAC 128kbps), but that's not the full story. The rest of the story is on the Stream Quality window where you have selected two different resolutions/bit rates, etc.

To add YouTube to this, you would click the #3 and select YouTube as Destination, enter stream key, etc. Then back in Stream Quality you would add a third stream at your chosen resolution/but rate for YouTube. Test that and see what you get.

Also, if you'll check the Hardware Encoder box, vMix will use processing power of your graphics card (GPU) in addition to your CPU, effectively cutting down your CPU usage, sometimes significantly.

Good luck!

- Tom
FBCAV  
#11 Posted : Tuesday, April 18, 2017 8:45:50 AM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

sinc747 wrote:
Now, in your example the Stream Quality settings window for Sunday Streams 0930 Service shows a single quality setting (like H264 Multi Bitrate 720p 1.5mbps AAC 128kbps), but that's not the full story. The rest of the story is on the Stream Quality window where you have selected two different resolutions/bit rates, etc.

To add YouTube to this, you would click the #3 and select YouTube as Destination, enter stream key, etc. Then back in Stream Quality you would add a third stream at your chosen resolution/but rate for YouTube. Test that and see what you get.

Also, if you'll check the Hardware Encoder box, vMix will use processing power of your graphics card (GPU) in addition to your CPU, effectively cutting down your CPU usage, sometimes significantly.

Good luck!

- Tom


Hi Tom,
Well now, perhaps (hopefully) *I* am the one who is dense here...

Are you saying that the #1, #2 and #3 bit rate settings on the Stream Quality settings coincide with the 3 buttons at the top of the Stream Settings window?? I.e. As I have Sunday Streams configured under Stream Setting 1 and Youtube under Stream Setting 2, that would explain why I get 720p to Sunday Streams and 360p to Youtube?

If so, that's my problem...although I'm not sure why when I unchecked the 360p quality setting, Youtube still got a stream, unless it defaulted to the stream settings of #1?

Thanks,
Jeff
sinc747  
#12 Posted : Tuesday, April 18, 2017 3:30:41 PM(UTC)
sinc747

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 984
Man
United States
Location: Fairhope, Alabama USA

Thanks: 498 times
Was thanked: 191 time(s) in 157 post(s)
FBCAV wrote:
Are you saying that the #1, #2 and #3 bit rate settings on the Stream Quality settings coincide with the 3 buttons at the top of the Stream Settings window?? I.e. As I have Sunday Streams configured under Stream Setting 1 and Youtube under Stream Setting 2, that would explain why I get 720p to Sunday Streams and 360p to Youtube?

If so, that's my problem...although I'm not sure why when I unchecked the 360p quality setting, YouTube still got a stream, unless it defaulted to the stream settings of #1?


@Jeff

I made a similar config error when I started, so I'm welcoming you to the club.

As for why YouTube got a 360p stream is beyond me.

Give it a try and report back.

- Tom
FBCAV  
#13 Posted : Tuesday, April 18, 2017 4:24:46 PM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

sinc747 wrote:
I made a similar config error when I started, so I'm welcoming you to the club.
As for why YouTube got a 360p stream is beyond me.
Give it a try and report back.


Hi Tom,
Will do.

Am I correct, though, that the 3 bitrate settings coincide with the 3 available stream "button" selections in the Stream Quality Window, i.e. the 1st bitrate setting is for the Button 1 stream, the 2nd for Button 2, and the 3rd Button 3?

If so, then that's why Youtube was getting 360p: I used the 2nd "button" for the Youtube url, and the (corresponding?) 2nd bitrate quality setting was 360p.

Thanks,
Jeff
sinc747  
#14 Posted : Wednesday, April 19, 2017 3:55:28 PM(UTC)
sinc747

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 984
Man
United States
Location: Fairhope, Alabama USA

Thanks: 498 times
Was thanked: 191 time(s) in 157 post(s)
FBCAV wrote:
Am I correct, though, that the 3 bitrate settings coincide with the 3 available stream "button" selections in the Stream Quality Window, i.e. the 1st bitrate setting is for the Button 1 stream, the 2nd for Button 2, and the 3rd Button 3?

If so, then that's why Youtube was getting 360p: I used the 2nd "button" for the Youtube url, and the (corresponding?) 2nd bitrate quality setting was 360p.

Thanks,
Jeff


You are correct!

- Tom
FBCAV  
#15 Posted : Wednesday, April 19, 2017 4:20:22 PM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

sinc747 wrote:
FBCAV wrote:
Am I correct, though, that the 3 bitrate settings coincide with the 3 available stream "button" selections in the Stream Quality Window, i.e. the 1st bitrate setting is for the Button 1 stream, the 2nd for Button 2, and the 3rd Button 3?

If so, then that's why Youtube was getting 360p: I used the 2nd "button" for the Youtube url, and the (corresponding?) 2nd bitrate quality setting was 360p.

Thanks,
Jeff


You are correct!

- Tom



Okay! So, it seems that what I have to do to make this work then is set up the following:

Button 1 = Sunday Stream's multi-bitrate url/key
Bitrate setting 1 = 720p
Button 2 = Sunday Stream's multi-bitrate url/key
Bitrate setting 2 = 360p
Button 3 = Youtube's standard url/key
Bitrate setting 3 = 720p

I've got the same question in to Sunday Streams, so we'll see :)

Thanks,
Jeff
sinc747  
#16 Posted : Thursday, April 20, 2017 11:51:36 AM(UTC)
sinc747

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 984
Man
United States
Location: Fairhope, Alabama USA

Thanks: 498 times
Was thanked: 191 time(s) in 157 post(s)
The proof is in the pudding! Give it a try!

- Tom
FBCAV  
#17 Posted : Monday, May 1, 2017 4:38:32 PM(UTC)
FBCAV

Rank: Member

Groups: Registered
Joined: 4/10/2017(UTC)
Posts: 13
Location: Glen Burnie, Maryland

sinc747 wrote:
The proof is in the pudding! Give it a try!

- Tom


Well, that seems to have been the trick, folks.
I set up 3 streams in the profile and matched the bitrate 1,2,3 entries to the stream 1,2,3 entry buttons and both Youtube and Sunday Streams are getting 720p and the phone apps that would get 360p are also working.
The only tricky part was, for the Sunday Streams feed, I used their standard stream url for the 720p and their multibitrate stream for the 360p stream, as when I tried to use the multi-bitrate stream for both, Vmix assumed I had duplicated one and "helped me out" by removing it. I suspect it wouldn't matter which URL I used for which resolution, just that they were different.

Thanks to everyone for helping me work through this while I still have my hair ;)

Jeff
sinc747  
#18 Posted : Monday, May 1, 2017 7:13:00 PM(UTC)
sinc747

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 984
Man
United States
Location: Fairhope, Alabama USA

Thanks: 498 times
Was thanked: 191 time(s) in 157 post(s)
I love it when people persevere through trials to success!

Well done, Jeff!

- Tom
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.