vMix - Live Production Software
Live Production Software Forums       www.vmix.com
Welcome Guest Search | Active Topics | Log In | Register

Tag as favorite
Cannot see multiple NDI machines
NHT
#1 Posted : Wednesday, 14 December 2016 12:05:54 AM
Rank: Newbie

Medals:

Groups: Registered
Joined: 17/04/2016
Posts: 9
Location: United Kingdom

Thanks: 0 times
Was thanked: 1 time(s) in 1 post(s)
Hi, I have vMix installed on 3 machines and if I try to use NDI on any of them I just get the spinny wheel next to the NDI logo.

Do I need to install any additional software, the vMix video tutorial makes it look very simple :/

Many thanks for any help :)
IceStream
#2 Posted : Wednesday, 14 December 2016 12:12:13 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 7/03/2012
Posts: 1,424
Location: Canada

Thanks: 15 times
Was thanked: 223 time(s) in 215 post(s)
@ NHT

What are the specs of your respective machines?
And I assume they are all connected to a gigabit switch on the same Network?


Ice
pm
#3 Posted : Wednesday, 14 December 2016 12:41:40 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 28/11/2015
Posts: 56

Thanks: 0 times
Was thanked: 10 time(s) in 7 post(s)
For NDI discovery, also the network location type of each computer has to be private. So please check this on your machines.

See this link for background information:
https://newtekinc.zendes...covery-and-Registration

And this link for changing the network location type:
https://www.itechtics.co...etwork-type-windows-10/

Regards,
Patrick
NHT
#4 Posted : Wednesday, 14 December 2016 2:31:27 AM
Rank: Newbie

Medals:

Groups: Registered
Joined: 17/04/2016
Posts: 9
Location: United Kingdom

Thanks: 0 times
Was thanked: 1 time(s) in 1 post(s)
IceStream wrote:
@ NHT

What are the specs of your respective machines?
And I assume they are all connected to a gigabit switch on the same Network?


Ice


Hi Ice, thanks for the reply.

2 machines are Windows 7Pro 64, one is 8.1 and they're all plugged in to a Netgear Gigaswitch.
NHT
#5 Posted : Wednesday, 14 December 2016 9:26:51 PM
Rank: Newbie

Medals:

Groups: Registered
Joined: 17/04/2016
Posts: 9
Location: United Kingdom

Thanks: 0 times
Was thanked: 1 time(s) in 1 post(s)
pm wrote:
For NDI discovery, also the network location type of each computer has to be private. So please check this on your machines.

See this link for background information:
https://newtekinc.zendes...covery-and-Registration

And this link for changing the network location type:
https://www.itechtics.co...etwork-type-windows-10/

Regards,
Patrick



Thanks for the reply Patrick.

All the machines are set to home network and have SSSE3 capable chips.

All the machines can see each other over a standard Windows network.

Is there anything special you need to do regarding IP addresses or DNS?


Neil.
pm
#6 Posted : Wednesday, 14 December 2016 10:17:10 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 28/11/2015
Posts: 56

Thanks: 0 times
Was thanked: 10 time(s) in 7 post(s)
No, nothing more regarding IP and DNS.

Is NDI enabled in vMix settings?
NHT
#7 Posted : Wednesday, 14 December 2016 10:37:19 PM
Rank: Newbie

Medals:

Groups: Registered
Joined: 17/04/2016
Posts: 9
Location: United Kingdom

Thanks: 0 times
Was thanked: 1 time(s) in 1 post(s)
pm wrote:
No, nothing more regarding IP and DNS.

Is NDI enabled in vMix settings?


Awesome! Working.

PM, you sir are a gent.

It probably would've been good if they'd put this at the beginning of the video tutorial... :/
pm
#8 Posted : Wednesday, 14 December 2016 10:41:28 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 28/11/2015
Posts: 56

Thanks: 0 times
Was thanked: 10 time(s) in 7 post(s)
You're welcome!

Regards
Patrick
Digitalson
#9 Posted : Sunday, 8 January 2017 5:16:53 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 17/01/2016
Posts: 109
Location: Nj

Thanks: 0 times
Was thanked: 4 time(s) in 4 post(s)
I had same problem and found out firewall was blocking one computer
doggy
#10 Posted : Tuesday, 10 January 2017 7:49:51 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 27/12/2012
Posts: 400
Location: Belgium

Thanks: 32 times
Was thanked: 38 time(s) in 33 post(s)
Also a connection problem trying various scenarios on a local machine

overall NDI seems to work as it should
- vMix in and out OK
- NT Telestrator(demo) OK
- NT Connect OK
- NT Transmit (demo) OK
- NT tools (monitor, testpattern) OK
- NT SDK examples c# NDI recv, wpf ndi send and scoring overlay with control based on the latter OK

NOW not OK

- NDI ISOCORDER free, nothing , doesn't see any local sources
- NDI Access Manager , is one supposed to see sources ? so one can put them in groups etc ?
- SSD Example "managed NDI send" only sends frame every 10 seconds (was no problem in v1 sending 29,97 fps)!

please some help , tried all the already given hints here and in docs i believe
Windows 10, Hooked up to router (else of course nothing works)
kane
#11 Posted : Tuesday, 10 January 2017 12:46:03 PM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 24/03/2016
Posts: 115
Location: Chicago, IL

Thanks: 0 times
Was thanked: 29 time(s) in 23 post(s)
NDI Access Manager doesn't show NDI sources, it just allows you to create groups. It will not show you the groups on the network, you need to know what they are (or look at another system and add it to the same groups).

I think NDI IsoCorder will only see sources on the network and not local NDI sources on the same computer.

Not sure on the other issue. If you signed up for the SDK, I would recommend posting a message on the NewTek forums in the NDI development section.

Kane Peterson
NewTek
doggy
#12 Posted : Thursday, 12 January 2017 6:24:47 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 27/12/2012
Posts: 400
Location: Belgium

Thanks: 32 times
Was thanked: 38 time(s) in 33 post(s)
kane wrote:


I think NDI IsoCorder will only see sources on the network and not local NDI sources on the same computer.



Seems indeed to be the case. Would have been nice if that was stated somewhere or not have the option to "choose" locally

SO finally coul dtest recording , hmm, nothing is able to play the result (have the codecs installed) not even vMix

Guy
doggy
#13 Posted : Thursday, 12 January 2017 6:28:37 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 27/12/2012
Posts: 400
Location: Belgium

Thanks: 32 times
Was thanked: 38 time(s) in 33 post(s)
kane wrote:

Not sure on the other issue. If you signed up for the SDK, I would recommend posting a message on the NewTek forums in the NDI development section.



Did and waiting

something strange though
say I open it in vMix, or Monitor I have the problem. Nnow if I open it in monitor and then ALSO in vMix it starts running as it should. seems vMix is able to somehow trigger it to run

Edit: when it is openend in 2 monitors or twice in vMix it runs
DWAM
#14 Posted : Thursday, 12 January 2017 7:04:47 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 20/03/2014
Posts: 111
Location: Bordeaux, France

Thanks: 10 times
Was thanked: 18 time(s) in 15 post(s)
doggy wrote:

nothing is able to play the result (have the codecs installed) not even vMix


On machines with NDI codec installed, I can play IsoCorder SHQ2 MOV files with Media Player Classic/Home Cinema (http://www.cccp-project.net/) and Premiere.
VLC or Resolve won't play them. I realize I didn't even try with FFMPEG so far.

For your other ploblem, just a guess: you may have a conflict between NDI v1 and NDI v2 dlls. I have noticed such things and Martin (Zenvideo) told me about this.
doggy
#15 Posted : Thursday, 12 January 2017 7:36:13 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 27/12/2012
Posts: 400
Location: Belgium

Thanks: 32 times
Was thanked: 38 time(s) in 33 post(s)
Quote:
you may have a conflict between NDI v1 and NDI v2 dlls


crossed my mind too, am pretty sure I eliminated that as I uninstalled i cleared all folders etc aswel to be sure it was not just "overwritten" but be new
DWAM
#16 Posted : Thursday, 12 January 2017 7:47:46 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 20/03/2014
Posts: 111
Location: Bordeaux, France

Thanks: 10 times
Was thanked: 18 time(s) in 15 post(s)
I'm not sure one can be sure about this. ;o)

Even Newtek NDI apps use both versions if available. For example do you remember having to update anything after v2 release ? I don't... IsoCorder app is the same since at least March 2016 (I tried last week)
I also encountered an issue trying to launch IsoCorder at the same time as a third party app (vMixUTC). Had to close it so IsoCorder can see my sources...
Really difficult to see clearly what's going on with NDI universe at the moment I think. I love it but not everything is rock solid as vMix !
DWAM
#17 Posted : Thursday, 12 January 2017 7:50:33 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 20/03/2014
Posts: 111
Location: Bordeaux, France

Thanks: 10 times
Was thanked: 18 time(s) in 15 post(s)
NDI SHQ2 codec for Windows and Mac can be downloaded here http://www.newtek.com/downloads
kane
#18 Posted : Thursday, 12 January 2017 9:31:25 AM
Rank: Advanced Member

Medals:

Groups: Registered
Joined: 24/03/2016
Posts: 115
Location: Chicago, IL

Thanks: 0 times
Was thanked: 29 time(s) in 23 post(s)
By NDI codecs I'm assuming you are talking about SpeedHQ. There are SpeedHQ codecs for both AVI and Quicktime media frameworks. However, the application in question does need to support one of these frameworks in order to use the codec. This would be anything that uses the Apple Quicktime libraries (like Quicktime Player) or DirectShow (like Windows Media Players). Applications that are FFMPEG based (like VLC Player) don't have support for SpeedHQ (yet!) and don't support Quicktime/AVI codecs, so they will not be able to play SpeedHQ based files.

Kane Peterson
NewTek
Users browsing this topic
Guest
Tag as favorite
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAFPro Theme Created by Jaben Cargman (Tiny Gecko)
Powered by YAF | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 0.098 seconds.